website pop up marketing Cisco Commands
Cisco CCNA | CCNP Certification Training Site. Cisco tips and tools for exam success. logo video
home | Cisco Commands
 

Cisco IOS Commands - CCNA Level

A good working knowledge of Cisco IOS commands is vital for your success in your Cisco exam. You will be tested on them during the switch and router simulations and also in the multiple choice questions.

Here are what we think are the most important ones you need to know along with how to apply them to live Cisco equipment. If you think we have missed any out please drop us a line to help at howtonetwork.net

Unprivileged Commands

enable lock ping
telnet tracerouteresume
disconnect ssh exit

Privileged Commands

configure terminal debug setup
copy running-config startup-config erase startup-config write
clock set clear reload
write terminal undebug allcopy tftp startup-config
copy running-config tftp copy tftp running-config copy startup-config running-config
terminal monitor copy startup-config tftp

Configure Commands

ip domain-lookup no hostname
config-register clock timezone alias exec
logging consoledo default interface
interface router username
ip classless ip subnet-zero ip default-gateway
ip dhcp pool enable secret ip domain-name
ip host ip http serverip name-server
ip route access-list (standard) access-list (extended)
ip access-list service password-encryption interface loopback
endlogging buffered banner motd
router rip router eigrp <As>router ospf <process id>
ip nat pool ip nat inside source list ip nat inside source static
ip dhcp excluded-address   enable password

Interface Commands

ip address clock rate encapsulation
bandwidth description duplex
no shutdown / shutdownencapsulation dot1q keepalive
ip access-group ip bandwidth-percent (EIGRP) ip directed-broadcast
ip helper-address (DHCP) ip mtu ip ospf #
ip ospf cost ip ospf priority ip ospf network broadcast
ip ospf network non-broadcast ip ospf network point-to-pointip ospf network point-to-multipoint
ip ospf hello-interval ip ospf dead-interval cdp enable
ip rip send ip rip receive speed
mac-addressip split-horizon (RIP) ip split-horizon eigrp <As>
encapsulation ppp ppp authentication chapppp chap hostname
ppp chap password ppp pap sent-username encapsulation frame-relay
frame-relay interface-dlci frame-relay map ip frame-relay inverse-arp
ip nat insideip nat outside ip nat enable
ip address dhcp ppp authentication pap delay

Line console Commands

logging synchronous loginhistory size
exec-timeout length lockable
password privilege  

Line VTY Commands

logging synchronous login history size
exec-timeout length lockable
password privilegeaccess-class

Show Commands

show access-listsshow Running-config show startup-config
show running-config Interface show Clock show controllers
show debug show frame-relay map show frame-relay pvc
show frame-relay lmi show hosts show interfaces
show ip interfaces show ip interfaces briefshow sessions
show tech-support show ip access-lists show ip dhcp binding
show ip dhcp conflicts show ip dhcp pool show dhcp server
show ip eigrp interfaceshow ip eigrp neighbors show ip eigrp topology
show ip ospf interface show ip ospf interface brief show ip ospf neighbor
show ip ospf database show ip route show ip route rip
show ip route eigrp show ip route ospf show ip route connected
show ip nat translations show ip nat statisticsshow ip protocols
show cdp neighbors show cdp neighbors detail show dhcp lease
Filtering Output *

Router RIP Commands

version 2 no auto-summary network
passive-interface validate-update-source passive-interface default
maximum-paths distribute-listoffset-list
distance timers neighbor

Router EIGRP Commands

no auto-summary network distance
distribute-list eigrp router-id passive-interface
passive-interface default variance (EIGRP) offset-list
distance eigrp maximum-pathsneighbor

Router OSPF Commands

   network
passive-interface router-id passive-interface default
maximum-paths distribute-list auto-cost reference-bandwidth
distance distance ospf neighbor

Debug Commands

debug ip packet debug ip packet detail debug ip routing
debug ip eigrp debug ip ospf adj debug ip ospf events
debug ip ospf packetdebug ip rip  

Clear Commands

clear ip route * clear ip ospf process clear ip eigrp neighbors

Switch Commands

Privilege Commands

vlan database configure  

Vlan Database Commands

vlan exit show
vtp domain vtp pruning vtp server
vtp client vtp transparent vtp password
apply   

Configure Commands

vlaninterface vlan interface range
vtp mode server vtp mode client vtp mode transparent
vtp domain vtp password spanning-tree backbonefast
vtp pruning spanning-tree portfast ip default-gateway
spanning-tree vlan root primary spanning-tree vlan root secondaryspanning-tree vlan priority
spanning-tree uplinkfast    

Interface Commands

switchport mode access switchport mode trunk switchport nonegotiate
spanning vlan cost switchport trunk encapsulation dot1q switchport trunk encapsulation isl
switchport trunk native vlan spanning-tree port-priority switchport trunk allowed vlan
switchport access vlan switchport port-securityswitchport port-security mac-address
spanning-tree vlan port-priority switchport port-security maximum switchport port-security violation
spanning-tree cost spanning-tree guard root  
spanning-tree portfast   

Show Commands

show vlanshow vlan brief show interface trunk
show spanning-tree show spanning-tree vlan show vtp status
show port-sec show mac-address-table show interface

Special Keys Commands

Tab

Return (at the --More-- prompt)

space Bar (at the --More-- prompt)
Ctrl-F

Esc-B

Esc-F

Ctrl-A

Ctrl-E

Ctrl-D

Esc-D

Ctrl-W

Ctrl-K

Ctrl-U or Ctrl-X

Up Arrow or Ctrl-P

Down Arrow or Ctrl-N

Ctrl-Y

Ctrl-Z Ctrl-shift-6, x

This site and/or material is not sponsored by, endorsed by, or affiliated with Cisco Systems, Inc. and/or its affiliates. Cisco®, Cisco Systems®, CCDA™, CCNA™, CCDP™, CCNP™, CCIE™, or CCSI™ are trademarks or registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.

Home | Search | Contact Us | Tell a Friend | Text Size

2006-2013 HowtoNetwork.net All Rights Reserved. Reproduction without permission prohibited.
Reality Press, Midsummer Court, 314 Midsummer Blvd.,Milton Keynes, MK92UB, UK

This site is powered by MemberGate Membership Site Software